summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL19
1 files changed, 19 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..f0fe012
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,19 @@
+use 5.006;
+use ExtUtils::MakeMaker;
+use Config(%Config);
+
+$defines= '-DHAS_SYSMKDEV'
+ if ($Config{osname} eq 'solaris');
+$defines= '-DHAS_SYSSYSMACROS'
+ if (defined $Config{d_gnulibc});
+
+# See lib/ExtUtils/MakeMaker.pm for details of how to influence
+# the contents of the Makefile that is written.
+WriteMakefile(
+ NAME => 'Unix::Mknod',
+ VERSION_FROM => 'lib/Unix/Mknod.pm', # finds $VERSION
+ ($] >= 5.005 ? ## Add these new keywords supported since 5.005
+ (ABSTRACT_FROM => 'lib/Unix/Mknod.pm', # retrieve abstract from module
+ AUTHOR => 'Jim Pirzyk <pirzyk@uiuc.edu>') : ()),
+ DEFINE => $defines
+);